安全研究

威胁情报
Samba远程代码执行(CVE-2017-7494)威胁通告

5月24 07:21:14 UTC 2017,Samba官方发布消息,Samba服务器软件存在远程执行代码漏洞。攻击者可以利用客户端将指定库文件上传到具有可写权限的共享目录,会导致服务器加载并执行指定的库文件。CVE编号为CVE-2017-7494


参考内容如下:

https://lists.samba.org/archive/samba-announce/2017/000406.html


简介

Samba是一个能让类Unix计算机和其它MS Windows计算机相互共享资源的软件。Samba提供有关资源共享的三个功能,包括:smbd,可以使类Unix计算机能够共享资源给其它的计算机;smbclient是让类Unix计算机去存取其它计算机的资源;最后一个smbmount是类似MS Windwos下“网络此磁盘驱动器”的功能,可以把其它计算机的资源挂载到当前系统下。


受影响的版本

  • Samba Version < 4.6.4
  • Samba Version < 4.5.10
  • Samba Version < 4.4.14
不受影响的版本
  • Samba Version = 4.6.4
  • Samba Version = 4.5.10
  • Samba Version = 4.4.14

官方建议

Samba官方已经提供了新版本来修复上述漏洞,请受影响的用户尽快升级到新版本,下载链接如下:

https://download.samba.org/pub/samba/stable/samba-4.6.4.tar.gz

https://download.samba.org/pub/samba/stable/samba-4.5.10.tar.gz

https://download.samba.org/pub/samba/stable/samba-4.4.14.tar.gz


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


浏览次数:

关 闭