安全研究

威胁情报
WordPress 远程代码执行/非授权重置密码

当地时间5月3日(北京时间5月4日凌晨),WordPress被曝出存在严重的安全隐患。

一则关于漏洞CVE-2016-10033的新POC被爆出。这是一个PHPMailer的漏洞,WordPress 4.6使用了存在该漏洞的PHPMailer,出于安全考虑,WordPress官方在4.7.1中更新了PHPMailer,解决了这个问题。但PHPMailer漏洞的原作者,又发现了一个针对PHPMailer在使用exim4 MTA时的利用方法。新POC的曝出也表示着WordPress 4.6版本均受影响。

一个新的漏洞(CVE-2017-8295)被发现存在于所有WordPress版本中。该漏洞源于WordPress在创建密码重置的电子邮件时,会使用客户端发送的SERVER_NAME变量的内容来构成发送者的邮件地址。攻击者如果知道管理员或任意目标用户的邮箱地址,可以首先通过发送大量邮件等方法使得目标邮箱无法正常收信,然后伪造一个发件邮箱来向目标邮箱发起重置密码的请求,该邮件会因为目标邮箱无法正常收信而退回攻击者控制的发件邮箱,攻击者就可以在退信邮件中获取重置密码的链接,从而重置任意用户的账户密码。该漏洞WordPress官方尚未有任何修复更新。

相关链接:

https://exploitbox.io/vuln/WordPress-Exploit-4-6-RCE-CODE-EXEC-CVE-2016-10033.html

https://exploitbox.io/vuln/WordPress-Exploit-4-7-Unauth-Password-Reset-0day-CVE-2017-8295.html


WordPress

WordPress是一个免费的基于PHP和MySQL的开源内容管理系统(CMS)。截至2017年2月,排名前1000万的网站中有超过27.5%的网站使用WordPress据报道WordPress是最受欢迎的网站管理或博客系统,支持6000多万个网站。


受影响的版本

CVE-2016-10033漏洞:
 • WordPress Version 4.6
CVE-2017-8295漏洞:
 • WordPress Version <= 4.7.4


不受影响的版本

 • CVE-2016-10033漏洞:
WordPress Version >= 4.7.1
 • CVE-2017-8295漏洞:

注:目前所有WordPress版本(包括最新的4.7.4版本)均受影响。


临时防护方案

 • CVE-2016-10033漏洞修补防护方案:

这个漏洞已经于WordPress 4.7.1版本中被修复,但建议用户升级到最新的4.7.4版本 因为还有其他安全漏洞被修复。

下载链接:https://wordpress.org/download/

 • CVE-2017-8295漏洞规避方案:

目前WordPress官方没有相关修复与更新,用户可以采取以下临时防护方案:

用户可以开启UseCanonicalName来强制使用静态SERVER_NAME值。

参考链接:https://httpd.apache.org/docs/2.4/mod/core.html#usecanonicalname


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


浏览次数:

关 闭