安全研究

威胁情报
Apache Struts2(S2-048)远程代码执行漏洞 威胁预警通告

2017年7月7日,Apache Struts发布最新的安全公告,Apache Structs2的strus1插件存在远程代码执行的高危漏洞,漏洞编号为CVE-2017-9791S2-048)。攻击者可以构造恶意的字段值通过Struts2的Struts1的插件,远程执行代码。

相关链接如下:

https://cwiki.apache.org/confluence/display/WW/S2-048

 

影响版本:

Apache Struts Version:2.3.x


不受影响的版本:

Apache Struts Version:2.5.10.1


规避方案

·  关闭Showcase插件。

·  受影响的用户可以升级到2.5.10.1版本。

·  开发者通过使用resource keys替代将原始消息直接传递给ActionMessage的方式。 如下所示:



不要使用如下的方式:


·  在非必要的情况下禁用struts2-struts1-plugin插件。将struts2-struts1-plugin-2.3.x.jar文件从 “/WEB-INF/lib”目录中移动到其他文件夹或者删除。


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


浏览次数:

关 闭