安全研究

威胁通告
GoAhead httpd/2.5 to 3.5 LD_PRELOAD 远程代码执行漏洞(CVE-2017-17562)

综述

    GoAhead Web Server在3.6.5之前的所有版本中存在一个远程代码执行漏洞(CVE-2017-17562)。该漏洞源于使用不受信任的HTTP请求参数初始化CGI脚本环境,并且会影响所有启用了动态链接可执行文件(CGI脚本)支持的用户。当与glibc动态链接器结合使用时,使用特殊变量(如LD_PRELOAD)可以滥用该漏洞,从而导致远程代码执行。

参考链接:

https://www.elttam.com.au/blog/goahead/

https://github.com/embedthis/goahead/issues/249


受影响的版本

  GoAhead Web Server Version < 3.6.5


不受影响的版本

  GoAhead Web Server Version >= 3.6.5


解决方案

GoAhead官方已经发布新版本修复了该漏洞,受影响的用户请尽快升级到最新版本进行防护。

参考链接:

https://github.com/embedthis/goahead/releases


关于GoAhead Web Server

GoAhead是“世界上最受欢迎的微型嵌入式Web服务器”, 结构紧凑,使用安全简单,被部署在数以亿计的设备中,如IBM,HP,Oracle,波音,D-link和摩托罗拉等公司,是最小的嵌入式设备的理想选择。

参考链接:https://embedthis.com/goahead/


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。


浏览次数:

关 闭