安全研究

研究报告
【处置手册】GoAhead httpd2.5 to 3.5 LD _ PRELOAD远程代码执行漏洞(CVE-2017-17562)

内容介绍

一.     漏洞概述

今日,GoAhead Web Server被爆出在3.6.5之前的所有版本中存在一个远程代码执行漏洞(CVE-2017-17562)。该漏洞源于使用不受信任的HTTP请求参数初始化分叉CGI脚本环境,并且会影响所有启用了动态链接可执行文件(CGI脚本)支持的用户。当与glibc动态链接器结合使用时,使用特殊变量(如LD_PRELOAD)就可以实施远程代码执行。2017年12月18日针对该漏洞利用的PoC公开,请受影响的用户及时更新版本进行修复。

    详情请参考如下链接:

     https://www.elttam.com.au/blog/goahead/

二.     影响范围

受影响的版本

GoAhead Web Server < 3.6.5

 

不受影响的版本

   GoAhead Web Server 3.6.5

   GoAhead Web Server 4.0.0


三.     防护方案

官方补丁

GoAhead官方已经发布新版本修复了该漏洞,受影响的用户请尽快升级到最新版本进行防护,以3.6.5版本为例,下载链接如下:

https://github.com/embedthis/goahead/archive/v3.6.5.zip

产品防护

用户可使用绿盟入侵防御系统NIPS、Web应用防火墙WAF或下一代防火墙NF对网络中的漏洞攻击报文进行阻断。


声 明

本安全公告仅用来描述可能存在的安全问题,绿盟科技不为此安全公告提供任何保证或承诺。由于传播、利用此安全公告所提供的信息而造成的任何直接或者间接的后果及损失,均由使用者本人负责,绿盟科技以及安全公告作者不为此承担任何责任。绿盟科技拥有对此安全公告的修改和解释权。如欲转载或传播此安全公告,必须保证此安全公告的完整性,包括版权声明等全部内容。未经绿盟科技允许,不得任意修改或者增减此安全公告内容,不得以任何方式将其用于商业目的。

查看完整内容请下载报告

《GoAhead httpd2.5 to 3.5 LD_PRELOAD远程代码执行漏洞(CVE-2017-17562)处置手册》


浏览次数:

关 闭